Can't login to my bulb — Bulb Community

Can't login to my bulb

Hi I'm trying to submit meter readings but no link is being sent therefore I can't login

Comments

  • @ruth2516 Could I ask what browser / device you are using? You can give me your meter readings on here so I can add them to your account now? We can then try and solve the login issues.
  • I am trying to log in to my account to submit reading s but no link is being sent
  • Hi @lee303 - please check your email, we've just sent you a link. If this doesn't work, please message here or email with your meter readings and we'll add them for you :)
  • Hi, im having the same problem, ineed to submit initial meter readings but cant get a link emailed to open an online account - how can i submit my readings?
  • Hi @Kwills,

    If you can't login to https://account.bulb.co.uk either with a password or trying the 'Email me a link to sign in instantly' option (check your spam box just in case and in, either case, ensure you are using the same email you signed up to Bulb with - if you have an email from them, check the email address they sent it to), drop Bulb an email or call them directly via https://help.bulb.co.uk/hc/en-us/articles/115001240291-How-can-I-get-in-touch-with-Bulb- and they'll be able to help. Include your postal/supply address as well so they can try to find your records that way .
  • kwills said:

    Hi, im having the same problem, ineed to submit initial meter readings but cant get a link emailed to open an online account - how can i submit my readings?

    DId you not set a password when first opening your account to start the switch? You must have. Try logging in with that password rather than requesting a link to be sent.
  • Sorted. I was bring adked for a reading before bulb had finished setting my account up, and so it wasnt recognising my email address
  • edited February 10
    kwills said:

    Sorted. I was bring adked for a reading before bulb had finished setting my account up, and so it wasnt recognising my email address

    Glad to hear you're all sorted.

    That's an odd problem though. The account is setup right at the start when you begin the switch. You should have been able to log in immediately after giving your email address and setting a password, so that you could follow the progress of your switch. Something must have gone wrong. Ah well, at least it's working now.
Sign In or Register to comment.