Bug Spotting/Squashing

@Will seems to be doing a good job with this shiny new community, but there are still a few bugs to squash.

So I’m going to start by posting here any that I find.

The notifications when you receive a badge have a hyperlink in the word “You” and the badge name, the one “You” leads to /profile/you rather than a unique link. (Tested on mobile)

When within PM’s from a member, and they send a new message, when you select to view the new message the pages doesn’t move since your already there, reloading the pages doesn’t help, so you have to go to another part of the site then click the button. (Mobile)

Good idea, thanks for this.

Which badge did you get to receive that notification? Each badge has an individual message, so I’ll double check that it isn’t just that one.

Is this PM problem on the mobile site or the desktop site?

That was the Name Dropper badge.

Just looking at the mobile site ATM, I’ve not had a good look at the desktop one yet.

Cool, I’ll take a look.

Thanks.

Also the same bug with the First Comment badge.

Righto, looks like a bigger problem then.

Weird thing: when I view other members profiles I.e. yours Will, I get 1 new phantom PM that doesn’t exsit, the count always shows 1 on that page. And when I view my own profile I don’t get that but I get 1 notification shown instead. Little odd (on mobile again)

Another mobile one. Joined date seems wrong. Mine is showing 3 days before I joined, and last active time/data is wrong too. Your @will is 1st October. Think you have probably been here since lol

Scratch that, its just updated, don’t know if it caches the HTML too long or somthing weird. Let’s blame the dog.

Another mobile one. Joined date seems wrong. Mine is showing 3 days before I joined, and last active time/data is wrong too. Your @will is 1st October. Think you have probably been here since lol

Scratch that, its just updated, don’t know if it caches the HTML too long or somthing weird. Let’s blame the dog.

OK found the issue, example. Http://community.Bulb.co.UK/profile/will doesn’t update on my screen, whether that’s because the page caches or is broken I don’t know.

Http://community.bulb.co.UK/profile/comments/will is uptodate as is http://community.Bulb.co.UK/profile/discussions/will and http://community.Bulb.co.UK/profile/activity/will

OK that doesn’t work, all the full links work correctly. But clicking the avatar/username doesn’t. Though @mentions work.

This is probably just me.

Weird thing: when I view other members profiles I.e. yours Will, I get 1 new phantom PM that doesn't exsit, the count always shows 1 on that page. And when I view my own profile I don't get that but I get 1 notification shown instead. Little odd (on mobile again)

When a PM conversation gets too long, it jumps to a new page of replies. Unfortunately it leaves the unread message on the previous page and jumps to the new one so you have to click the “See older messages” button to see it. Is this what you mean?

Another mobile one. Joined date seems wrong. Mine is showing 3 days before I joined, and last active time/data is wrong too. Your @will is 1st October. Think you have probably been here since lol

Scratch that, its just updated, don’t know if it caches the HTML too long or somthing weird. Let’s blame the dog.

OK found the issue, example. Http://community.Bulb.co.UK/profile/will doesn’t update on my screen, whether that’s because the page caches or is broken I don’t know.

Http://community.bulb.co.UK/profile/comments/will is uptodate as is http://community.Bulb.co.UK/profile/discussions/will and http://community.Bulb.co.UK/profile/activity/will

Or its just my phone :confused:

Can you post a screenshot so I can see what you mean?

So when I click avatar/username I get the first, if I click anywhere else I get the second :confused:

Weird thing: when I view other members profiles I.e. yours Will, I get 1 new phantom PM that doesn't exsit, the count always shows 1 on that page. And when I view my own profile I don't get that but I get 1 notification shown instead. Little odd (on mobile again)

When a PM conversation gets too long, it jumps to a new page of replies. Unfortunately it leaves the unread message on the previous page and jumps to the new one so you have to click the “See older messages” button to see it. Is this what you mean?

Nope, I’m not too good at explaining :confused:

When you view another persons profile it shows a doorhanger for 1 new PM, there’s nothing there and it shows every time you view a profile, so the page must be defaulting to 1. If you have 1 real PM then it shows 2 on that page only.

And on my own profile it shows a doorhanger for a notification.

Also I keep using the wrong emoticon :confused:

@I_Am_Sy

I’ve been trying to reproduce the bugs you’ve raised this morning and I can’t make them happen. I think the problems with phantom PMs and it looking like I’m not logged in are probably cache issues. What browser, device and operating system are you using?

I’m also having trouble getting a badge notification that links to /profile/you, so I need your help reproducing it. Can you walk me through reproducing it step by step? Like I’m a 5 year old who has never used a community before.

If you need me to give you a testing badge to trigger a notification then just shout.

@I_Am_Sy

I’ve been trying to reproduce the bugs you’ve raised this morning and I can’t make them happen. I think the problems with phantom PMs and it looking like I’m not logged in are probably cache issues. What browser, device and operating system are you using?

I’m also having trouble getting a badge notification that links to /profile/you, so I need your help reproducing it. Can you walk me through reproducing it step by step? Like I’m a 5 year old who has never used a community before.

If you need me to give you a testing badge to trigger a notification then just shout.

Yeah I’ll try some other tech to see if it happens there.

Umm the badges. Can you give your testing account one (uploading a profile picture works best as it has “you” and “your”) and login to that account on mobile? Then just look at the notifications at the bottom and you should see the the hyperlinks to click.

Weirdly those links are now working for me when I click from http://community.Bulb.co.UK/profile/notifcations :confused:

You might want to give this whole lot a miss, no idea why it didn’t work though :confused:

Weirdly those links are now working for me when I click from http://community.Bulb.co.UK/profile/notifcations :/

You might want to give this whole lot a miss, no idea why it didn’t work though :confused:

We’ll put that down as one to watch out for then.

Well if everything keeps fixing its self it can’t be bad haha. I feel a little silly though as they don’t seem to be there :confused: