Chameleon device on smartthings

I just noticed on the smartthings app ‘Chameleon’ device has been added with reference to chameleoncloud but not active yet. Maybe it’ll let me connect my IHD3 with smartthings finally. Anyone else know anything about this?

1 Like

It works, just just need to use the Bulb app of Smarthings and the unique ID code of your IHD, plus the IHD needs to be paired to your WiFi at home too

The bulb Smartthings Energy Control never worked for me. I have a Chameleon IHD3 but a SMETS1 ‘Secure’ meter so just wondered if I’d be able to use smartthings for my energy monitoring with this update. I can get my data through Loop app at the moment or a real-time update on IHD.

Update - The SmartThings chameleon Device energy monitor tells me I don’t have a valid smart meter in my property after adding MPAN details.

Sorry to hear that @Stephie

I can confirm you definitely have a secure SMETS1 meter in your property for both electricity and gas.

Let me know if you have any other q’s or anything I can help with

– Daisy :bulb:

Thanks for replying, I know I have SMETS1 as thieves mentioned when I tried smartthings energy control with my IHD3 which whenever compatible even after updates and now smart again after DCC intergration still no luck, just ‘Invalid GUID’ error. I kinda hoped its work with the chameleon device option with having a chameleon ihd3. Maybe it’s the version I have, installed by BOOST ENERGY in 2018 IHD3-CAD Ref CA30201 0.10.0 with no internal battery.

Hi @Stephie

Sorry to hear you are having issues with the SmartThings app still.

Firstly I would just double check you have the newest version of the app installed.

If so here is a general guide on the app and here is a guide for troubleshooting when setting up the app.

Keep us posted as to how you get on

Ele :bulb:

1 Like

Hi @Ele_at_Bulb,

I’ve never been able to connect the smartthings app or hub to my SMETS1 meter or IHD3-CAD. The Bulb device and STEC always got ‘Invalid GUID’ error after entering the GUID from IHD and checked multiple times making sure it wasn’t mistyped. The Chameleon device option asked for the address and couldn’t find the meter then asked for the MPAN then saying “no valid meter found in the property”. The only successful attempt to get the data has been via loop. homes/ and their app. I just came across this citizens advice page

smartmetercheck. citizensadvice. org. uk

to check if meters are working and the meter can’t be found on here either but suggested maybe the meter isn’t fully enrolled in the DCC adoption database properly?

Hi @Stephie I’ve had a look and your meter isn’t on the DCC network. Instead, as it’s a Secure branded meter, it is on the Secure network. This works similarly but it’s not quite the same as the DCC.

This will be the reason it’s not working properly, and unfortunately I don’t think it’s something we can fix at this time. I’m really sorry about this. – Miriam :bulb:

1 Like

Hi @miriam_at_bulb I hope this gets to you, I just wanted to say thank you so much for confirming the network status. That one little bit of information was exactly what I needed for peace of mind and an answer and new direction to look to get to the bottom of why my meter never fully connected to smartthings or any other services. My meter has now been connected to the DCC network and finally connected to smartthings via the chameleon device app. Early days with updating the energy usage but have signed up for the early access real-time updates with chameleon eive. Again thank you for your help and all the other customer service agents doing their bit and putting up with the persistent and sometimes relentless mither.

1 Like

hey @Stephie

Thanks so much for letting us know! I will be sure to pass your thanks on t Miriam :partying_face: :partying_face: :partying_face:

Glad we could help! Wishing you a lovely xmas :santa:

– Daisy :bulb: