Don’t understand welch smart mater

Why is my smart meter in welch. Cannot get reading for electric.

Type Welsh instead of welch in the help button for info.

@Curtis Here are some instructions on how to change it back to English :slight_smile:

Press the ‘OK’ button at the bottom of the In-Home Display, and then the right arrow button until you see ‘Gosodiadau Wedi anfon yr’.
Press OK. This takes you to settings.
Press the right button until you see ‘Dewis iaith Wedi anfon yr’. If this doesn’t work, you may need to try the next option, ‘Clirio Gosodidau Wedi anfon yr’.
Press OK.
Select English on the left by pressing the left button, then ‘OK’.

Where is the OK button?

Where is the OK button?

I don’t have an IHD, but from the previous answer is it at the bottom?