IHD displaying incorrect tarrifs

(upload://qDfF2S9zs8QiOHbLCDb0Xho01pA.jpeg)

Anyway to fix this? I’ve tried unplugging from the wall and turning off and on again.

Hi @davisonburns,

I’ve heard back from our Secure smart team regarding your case. Unfortunatley, as we didn’t install this type of IHD at the moment we’re unable to fix it so it displays the correct tariff. I’m very sorry about this.

They have recommended for now to change your readings to half hourly and following your usage through the Bulb app. You can do this via this link: https://account.bulb.co.uk/dashboard/smart/meter-settings