IHD not showing Electricity + Statement Issues

Hello,

My In-Home Display (IHD) is not showing my electricity usage. It is showing the gas usage.

I have done all the checks (connections etc.) and they all seem fine. I have moved the IHD closer to the meter and that hasn’t worked. I have switched it off for a few mins and put it back on, and this hasn’t worked. I have checked the meter itself and all of the lights flash every 5 seconds (which apparently means its fine), except the MESH light. Is that the Issue? If not, any idea on how to make my IHD sync with the Meter again, so that I can see the electricity usage on my IHD? Is this a firmware issue with IHD?

FYI - my IHD is the blocky plastic one (thick black bezels with white casing around the back)

My second question is, I recently moved to BULB on the 16th Feb. Payment is due on 15th March. Do you know when I will receive my monthly statement which shows the Gas/Electricity usage during this time?

Thank you in advance for your help.

Mikky

Hi @mcaje14 :wave:

Thanks for getting in touch.

  1. It’s good that you’ve tried these measures, I can confirm that the MESH light is not a cause for concern. Flashing light is a good sign :bulb:

I recommend trying this fix on the Bulb account.

Once you’ve sent that in we’ll try and fix your IHD overnight, so it should start working in 24 hours. If it’s still not working in 48 hours then get back in touch.

  1. Your monthly statement will be around the 16th of March, this will account for your first month with us (16th Feb - 16th March)

Let me know if that works.

  • Mel :raised_hands: