In Home Display will not acknowledge it is connected to the wireless network.

Trying to connect my new IHD to the wireless network. According to my server, the IHD has indeed connected, been given an IP address by the dhcp server, and I can ping it and get responses. (See screen copy below.). However the IHD itself is insisting that it isn’t connected and keeps trying to reconnect. Mostly the screen says “Connecting…”; sometimes changes briefly to “Connected, no internet”; throughout this the device responds to pings from another machine. Is this IHD faulty?


Sep 27 16:44:09 cooper-linux dhcpd: DHCPACK on 192.168.11.44 to 0e:a2:f4:41:ef:c2 via eth0
Sep 27 16:46:53 cooper-linux dhcpd: DHCPDISCOVER from 0e:a2:f4:41:ef:c2 via eth0
Sep 27 16:46:54 cooper-linux dhcpd: DHCPOFFER on 192.168.11.44 to 0e:a2:f4:41:ef:c2 via eth0
Sep 27 16:46:55 cooper-linux dhcpd: DHCPREQUEST for 192.168.11.44 (192.168.11.253) from 0e:a2:f4:41:ef:c2 via eth0
Sep 27 16:46:55 cooper-linux dhcpd: DHCPACK on 192.168.11.44 to 0e:a2:f4:41:ef:c2 via eth0
Sep 27 16:49:46 cooper-linux dhcpd: DHCPDISCOVER from 0e:a2:f4:41:ef:c2 via eth0
Sep 27 16:49:47 cooper-linux dhcpd: DHCPOFFER on 192.168.11.44 to 0e:a2:f4:41:ef:c2 via eth0
Sep 27 16:49:47 cooper-linux dhcpd: DHCPREQUEST for 192.168.11.44 (192.168.11.253) from 0e:a2:f4:41:ef:c2 via eth0
Sep 27 16:49:47 cooper-linux dhcpd: DHCPACK on 192.168.11.44 to 0e:a2:f4:41:ef:c2 via eth0
grahame@cooper-linux:/var/lib/dhcp $ tail -12 dhcpd.leases
}
lease 192.168.11.44 {
starts 5 2019/09/27 13:34:38;
ends 6 2019/09/28 13:34:38;
cltt 5 2019/09/27 13:34:38;
binding state active;
next binding state free;
rewind binding state free;
hardware ethernet 0e:a2:f4:41:ef:c2;
uid “\001\014\242\364A\357\302”;
client-hostname “chameleon-cad-0ea2f441efc2”;
}
grahame@cooper-linux:/var/lib/dhcp $ sudo ping 192.168.11.44
PING 192.168.11.44 (192.168.11.44) 56(84) bytes of data.
64 bytes from 192.168.11.44: icmp_seq=1 ttl=64 time=36.9 ms
64 bytes from 192.168.11.44: icmp_seq=2 ttl=64 time=60.3 ms
64 bytes from 192.168.11.44: icmp_seq=3 ttl=64 time=80.7 ms
64 bytes from 192.168.11.44: icmp_seq=4 ttl=64 time=139 ms
64 bytes from 192.168.11.44: icmp_seq=5 ttl=64 time=23.0 ms
64 bytes from 192.168.11.44: icmp_seq=6 ttl=64 time=46.0 ms
^C
— 192.168.11.44 ping statistics —
7 packets transmitted, 6 received, 14% packet loss, time 6008ms
rtt min/avg/max/mdev = 23.036/64.473/139.674/38.192 ms

Having exactly the same problem. My broadband signal is high but the IHD, which is no further than 10 metres away from my home hub will not respond. It shows it’s connected to my WiFi but it says no internet connection. Looks like faulty IHD’s

We have just had ours installed and exactly the same issue. Bulb, you aware of these issues and is there a solution?

Same problem. Funny that the engineer said it didn’t need the Wi-Fi connection. I’m guessing he knew it wouldn’t have connected.

Also seeing the same issue (IHD6). I read something on another forum from more than a year ago that these devices have a specific hard-coded NTP server (rather than using a pool) and if it fails to connect to that then it thinks it’s offline.

Connecting the IHD to WiFi is pointless. The IHD receives data from the electricity meter.
WiFi is something Bulb intend to use in the distant future!

@Johno It probably is, but I was wondering if firmware updates are possible when it’s connected to WiFi. It would be nice if they could push improvements - for example it would be good if the IHD could show both import and export meter readings instead of just import.

Same here, which means connecting to the Samsung app isn’t an option - https://bulb.co.uk/blog/were-partnering-with-samsung-to-help-you-get-more-out-of-your-smart-meter

Hi all. Any solution to this problem yet? My smart meters have been installed today, but my IHD won’t connect to WiFi, it keeps saying ‘connecting’…

exactly the same issue here, smart meter just installed and won’t acknowledge it’s wifi connection. tried connecting it to a mobile hotspot too in case it was incompatible with my router, but same issue

Also seeing the same issue (IHD6). I read something on another forum from more than a year ago that these devices have a specific hard-coded NTP server (rather than using a pool) and if it fails to connect to that then it thinks it's offline.

I’ve looked at the traffic from/to the IHD. It is successfully getting the time from 0.cham.pool.ntp.org, doing DNS lookups for a server at r55np2.messaging.chameleoncloud.co.uk, and then holding conversations with that server on a secure internet of things messaging port. Everything seems to be working fine as far as the network connection is concerned, but all the while it contiinues to say “Connecting …” on the screen, occasionally changing briefly to “Connected, no internet.”

Just had mine installed and it’s exactly the same just sits there saying connecting.

I've looked at the traffic from/to the IHD. It is successfully getting the time from 0.cham.pool.ntp.org, doing DNS lookups for a server at r55np2.messaging.chameleoncloud.co.uk, and then holding conversations with that server on a secure internet of things messaging port. Everything seems to be working fine as far as the network connection is concerned, but all the while it contiinues to say "Connecting ..." on the screen, occasionally changing briefly to "Connected, no internet."

Thanks for checking - yes it looks like they’ve fixed that previous issue by switching to a pool. As far as the router is concerned the device is connected and I can ping it on the local network. Unfortunately it doesn’t appear to have any open ports for maintenance purposes and the USB connection on the back is purely for power - no data.