Linking IHD with smartthings app

Smart meter installed yesterday. Have linked IHD to my wifi via router. Now trying to get smartthings app to accept the GUID of the IHD device. It keeps telling me the number is invalid. I have typed numerous times, checked the 0vO potential, tried to scan rather than type but nothing is succeeding.

Any advice? TIA

1 Like

I have exactly the same issue. This is very frustrating.

I have emailed Bulb with screenshots of the code and the messages to prove I am not an eejit entering the wrong data. Hopefully I will get a reply during the working week.

Thanks for the tip.
I’ll try that too.

Exactly the same issues with INVALID GUID. I been trying to get somewhere with it for about a year speaking to bulb customer services and smartthings customer services but every answer is pointing to a dead end. Original meter and IHD from BOOST(OVO) installed 2018. SMETS1 secure meter, chameleon ihd3-cad CA30201 v0.10.0. Almost given up trying to get anything working but I’m just to naturally stubborn to accept it won’t work.
One thing I’ve not seen yet is the smartthings groovy api apps, devices and handlers for smartthings energy control from one that is working, thats a new thing to look at.

I’ve managed to link it with smart things app but it displays no usage, so even if you get this fixed I doubt it will still work :frowning:

I’m having the same issue - possible red herring, but the number printed on the IHD (and the number shown on boot) is one digit different to the actual Ethernet MAC address of the unit when it joins the network - I have no idea if this is relevant [I’m about to post in more detail]

Which one?
Don’t think the C/S at blub will comprehend “eejit” :rofl: :

Well it does not seem like this one that’s for sure!

1 Like

Hey everyone! @deborahcruickshank, @TonyDee, @Stephie, @temporaldoom, @nashenden.

Thanks for coming to Community. Have you taken a look at our SmartThings help centre?

If none of the help in that article works, please let me know here as it might be an IHD issue which we can take to our Smart team.


The Help Centre is pointless - it’s written for toddlers. The OP and myself have been quite clear about what the issue is, but you don’t seem to have understood that. The issue is that the Chameleon cloud is not recognising the provided GUID - either because the installer provided the wrong one, the cloud is set up wrong or (unlikely) its the wrong one on the box. In my case I’m fairly sure its because the IHD GUID is not setup on the Chameleon cloud, but I have no way to prove this.

I have certainly looked at all the help materials but unless the GUID number is accepted there can be no progress.

I am considering unplugging the IHD as it is simply using more energy by sitting plugged in! Seems pointless?

This is as far as I can get…

1 Like

A very familiar message! It’s not us, be assured.

1 Like


Samsung and Chameleon are currently running a live Q&A until 5pm today which might be of interest: Samsung SmartThings Energy Control - We are live today to answer your questions

Had smart meter installed just over 2 weeks ago. Have IHD6 in-home display (wifi successfully connected). Today got email from Bulb stating virtues of SmartThings app. Downloaded app and followed set-up instructions but every time I get to the ‘Account pairing’ bit, nothing happens. IHD just states “waiting…” for several minutes then reverts back to displaying usage. Have tried numerous times but am never getting those elusive 4 words needed to complete the pairing.
Is this a bad app or is the back end at Bulb not really ready for it yet - or am I doing something wrong?
Any help gratefully received.

Hi Rob

Thanks for your post and welcome to community :wave:

I’ve just reached out to our team who deals with SmartThings team to see why this may be.

In the mean time here is a general guide on the app, and here is a guide on how to pair your IHD to the app.

Could you let me know how you get on please?

Ele :bulb:


Thank you for looking at this. I have now successfully paired the device with the app. It eventually worked the next day (I followed exactly the same process as before). However, it was immensely frustrating that it did not work when I first tried (…on numerous occasions). I had started to conclude that it simply was not going to and that there must be some fundamental flaw in the software and/or platform.

Bearing in mind I was trying shortly after the email telling me about the app came out, my suspicion is that this might be down to how many simultaneous requests your platform can handle at one time. Maybe numerous others were also trying at same time?



Hi @Rob

I’m glad to hear you got it working, and sorry to hear that it was a frustrating process.

I’m unsure why it wasn’t working when you first tried it and we weren’t made aware of any issues, however like you said high inflow could be a potential cause for it running less effectively

Ele :sunny:

I’ve got the same issue when trying to link my IHD3 to the smartthings app. I’ve tried numerous times but still have the same error message as @Stephie.

Please can you help me sort this?