My smart meter is now displaying in welsh

Can you advise how do I change it back to english.

Go to Money Saving Expert: https://www.moneysavingexpert.com/news/2019/07/-my-smart-meter-is-speaking-welsh--/ Hope it helps!

Either follow Paul’s suggestion or use Google Translate!

Pwyswch y botwm ‘OK’ ar waelod yr arddangosfa gartref, ac yna’r botwm saeth dde nes i chi weld ‘Gosodiadau Wedi anfon yr’.
Pwyswch OK. Mae hyn yn mynd â chi i leoliadau.
Pwyswch y botwm cywir nes i chi weld ‘Dewis iaith Wedi anfon yr’. (Os nad yw hyn yn gweithio, efallai y bydd angen i chi roi cynnig ar yr opsiwn nesaf, ‘Clirio Gosodidau Wedi anfon yr’.)
Pwyswch OK.
Dewiswch Saesneg ar y chwith, drwy wasgu’r saeth chwith, yna ‘OK’.

@phproxy

:o

Pwyswch y botwm 'OK' ar waelod yr arddangosfa gartref, ac yna'r botwm saeth dde nes i chi weld 'Gosodiadau Wedi anfon yr'. Pwyswch OK. Mae hyn yn mynd â chi i leoliadau. Pwyswch y botwm cywir nes i chi weld 'Dewis iaith Wedi anfon yr'. (Os nad yw hyn yn gweithio, efallai y bydd angen i chi roi cynnig ar yr opsiwn nesaf, 'Clirio Gosodidau Wedi anfon yr'.) Pwyswch OK. Dewiswch Saesneg ar y chwith, drwy wasgu'r saeth chwith, yna 'OK'.

Press the OK button at the bottom of the display at home, and then the right arrow button until you see ’ settings sent in '.
Press OK. This takes you to venues.
Press the correct button until you see ’ select language sent in '. (If this does not work, you may need to try the next option, ’ clear set-up posted '.)
Press OK.
Select English on the left, by pressing the left arrow, then ’ OK '.