No electricity reading now in Welsh

My smart meter doesn’t show electricity readings, I followed the instructions for logging this issue but now the smart meter has switched to Welsh and won’t return to English (despite selecting the English option). How can this be rectified?

Hi @J_M_1

Sometimes, In-Home Displays can switch to Welsh. If this has happened to yours and you need to switch it back to English, here’s how:

  1. Press the ‘OK’ button at the bottom of the In-Home Display, and then the right arrow button until you see ‘Gosodiadau Wedi anfon yr’.
  2. Press OK. This takes you to settings.
  3. Press the right button until you see ‘Dewis iaith Wedi anfon yr’. If this doesn’t work, you may need to try the next option, ‘Clirio Gosodidau Wedi anfon yr’.
  4. Press OK.
  5. Select English on the left, by pressing the left arrow, then ‘OK’.

This should switch your In-Home Display to English.