Poor opinion of this IHD

Had our smart meter installed a week ago and, I have to say, my opinion of this In Home Device is pretty low!

  • After about 4 hours the device went into a crash/reboot cycle that simply wouldn’t stop. I eventually worked out that there was just enough time before it crashed again to go into the settings and select Clear Settings & Data to get it working again. So far it’s done this 4 times.
  • It connects to my wifi, but not for long. At first the little wifi icon stays steady, but after a while it starts flashing, which I take to mean that it’s no-longer connected.
  • I’ve followed the instructions, successfully it would appear, to connect it to SmartThings. It’s never brought in any data - just says “Getting the latest data… this may take a while”.

Do I have a faulty unit, or is this just how it is?

Cheers

My experience is that it takes a couple of weeks for the IHD to connect properly to wifi. I can’t provide any insight into the other things though - my SmartThings still doesn’t do anything and it’s been some months. Hopefully yours will start working soon.

Hi @Fabulosa, firstly welcome to Bulb community :wave:

As your IHD is restarting, I’ve requested a Comms hub (the white bit on top of your electricity meter) reboot, and this will re-establish the connection between your IHD and your meters. This should stop the IHD restarting and get your usage showing on there too. This can take up to 3 weeks, based on where you are in the country, so I appreciate your patience in the meantime.

Lou :sparkles:

Well, the constant rebooting seems to have stopped and the wifi is now constantly connected (at least the icon doesn’t flash any more) but the SmartThings integration still doesn’t work.

So I though I’d remove the current integration and try again, but now the “Pair CAD to Account” screen on the IHD just sits there on “waiting…” without ever bringing up the 4 word pairing phrase.

I don’t know how either the IHD or the SmartThings integration ever got through Quality Control!

Honestly, if this was a product that I had purchased I would have returned it by now.

Hi @Fabulosa,

Thank you for your update on your IHD.

I have raised this with our smart meter team who have attempted to remotely pair your smart meter. Please can you ensure the IHD is within 5m of your electricity meter and turned on.

Could you please update us over the next 1-5 working days if this fixes the issue?

Thank you for your patience so far.

Nathan

Yes, its within 5 metres and has all 4 bars on the signal strength and, yes, it is obviously turned on or else I wouldn’t be seeing anything on the screen at all!!

But no difference - still just sits there saying “waiting”.

Hi @Fabulosa

Sorry to hear of your continued IHD issues. I will request an update for you on this from the smart team and i’ll send you an email once I’ve heard back.

Nathan :bulb:

Stop wasting your time with the bulb chameleon IHD, if your meters are SMETS2 then other third party providers can offer you a free mobile app, or even sell you an IHD that works.

I’m still with Bulb, but using an IHD and app from a company called Hildebrand. Hassle free and so much more data than you get from Bulbs devices.

Thanks for the info - I didn’t know that was an option. But, I don’t see why I should have to shell out extra money just because Bulb can’t supply a product which works! Maybe they should be buying Hildebrand devices and sending them out to us (but I won’t hold my breath!)

In the meantime “waiting…” always waiting!

Hey @Fabulosa :wave:

We do not want you to pay extra money for a new IHD, we would like to fix the one you currently have.

We attempted to repair the IHD last week, we will follow up in an email today so we can keep you updated on this.

Best,
Carl :house:

I don’t know if this helps you but the time is 15:13 BST on 30/05/2021 and I’ve just tried again. Perhaps you might be able to search your logs to see if there’s a request.

This happened to me several times before it got sorted. I think the issue is less with Buib than the people who run the smart meter networks, so it will be the same whichever supplier you use. Whatever happens the readings don’t get lost, it’s just frustrating.

I’d download the Bright app Phytone3d mentions, you don’t need their IHD unless you want live consumption data on their app or want to do some detailed analysis of the information. It’s also much better than SmartThings.

I’m now at 2 years with a non-working IHD. Bulb won’t entertain the idea of replacing it, even though it’s clearly not capable of connecting to the comms hub (connects to WiFi fine), and reboots constantly because of lack of connection, so will never get the firmware update it apparently needs to be able to connect to the comms hub properly…
It’s still on the original firmware from when the smart meters were installed, and there’s been a few firmware updates since then, but my IHD is clearly incapable of getting it so it’ll never work.

Hi @ryan4257,

I replied to you on another thread, but I just spotted your suggestion of sending you a new IHD. This doesn’t always fix the issue, which is why we usually wait for the DCC to run a batch of remote fixes first. But I can add you to the IHD waitlist if you’d like? I can’t give you a timeframe on when we’d be able to send them out but if you’re on the waitlist you’ll be the first to know when we can. Let me know here if you want me to arrange that.

Georgie :bulb:

“waiting…” always waiting!

Hi @Fabulosa,

I’m sorry to hear you are still waiting for an update on your case. I will chase this up for you now and get back to you via email shortly.

Thanks
Nathan

This really is a joke!

So for the past 3 days my IHD has been displaying nothing - just the gas icon and “-----”. Today it reset itself and came back to life and, as I’m obviously a masochist, I thought I’d give the account linking a go.

Bloody Nora - it only went and worked!!

However… so far there’s no data in the SmartThings app, just “getting the latest data… this may take a while”.

And now, after about 3 hours, the IHD has gone back into one of those endless crash & reboot loops.

I think, if this was a commercial product that I had paid separately for, by now I would be contacting Trading Standards as this device obviously isn’t fit for the purpose.

And, this is such a shoddy product, if I were Bulb, I’d be threatening to sue Chameleon!

Hello @Fabulosa,

Thank you for sharing your update, I have passed this directly onto the smart team who are investigating this further now. Once i’ve heard back, I’ll drop you an email later on with an update.

Thanks

Nathan

Yeah, well thanks but you’ll pardon me for not holding my breath, seeing as how they contacted me 7 days ago for an update to see if something they’d done had worked, and I’ve been emailing them daily since then and they haven’t replied yet.

FYI, no it didn’t work and it’s now still stuck in a perpetual crash/reboot loop!

I am sorry that you didn’t recieve a response to your daily update emails. The smart team are aware of your responses on our side who are investigating your issue. As my colleague mentioned in his latest email, we are trying everything we can do remotely first before escalating the case further to find a solution.

As soon as we have an update for you, you’ll be the first to know :bulb: