Revert language from Welsh to English

I have tried the advice recommended, but this does not seem to work on my Smart Meter. It continues to read Welsh. Does anyone have any further ideas please?

Hey @Nick2019_Banbury

Did you follow these instructions?

Press the ‘OK’ button at the bottom of the In-Home Display, and then the right arrow button until you see ‘Gosodiadau Wedi anfon yr’.
Press OK. This takes you to settings.
Press the right button until you see ‘Dewis iaith Wedi anfon yr’. If this doesn’t work, you may need to try the next option, ‘Clirio Gosodidau Wedi anfon yr’.
Press OK.
Select English on the left, by pressing the left arrow, then ‘OK’.

The meter’s functionality is not impacted by the IHD not working properly, so please don’t worry about the meter as it will still be logging your usage correctly