Smart Meter in Wrong Language

Does anyone know how to change the language to English, it is currently showing Welsh. I have tried switching it off and on again but no change.

From a quick search for “Welsh” in the “Search discussions” box came up with these instructions from https://community.bulb.co.uk/discussion/comment/34757/#Comment_34757 :

To change from Welsh > English:

Press the ‘OK’ button at the bottom of the In-Home Display, and then the right arrow button until you see ‘Gosodiadau Wedi anfon yr’.
Press OK. This takes you to settings.
Press the right button until you see ‘Dewis iaith Wedi anfon yr’. If this doesn’t work, you may need to try the next option, ‘Clirio Gosodidau Wedi anfon yr’.
Press OK.
Select English on the left by pressing the left button, then ‘OK’.