smart meter language

Hi
My smart meter seems to be displaying in Welsh! Can anyone suggest how to set it back to English? I may have the surname Hughes but I’m not Welsh :slight_smile:

Help button. Then put “Welsh” into the search box. Croeso! :slight_smile:

Hi @Ruth18

To change from Welsh > English:

Press the ‘OK’ button at the bottom of the In-Home Display, and then the right arrow button until you see ‘Gosodiadau Wedi anfon yr’.
Press OK. This takes you to settings.
Press the right button until you see ‘Dewis iaith Wedi anfon yr’. If this doesn’t work, you may need to try the next option, ‘Clirio Gosodidau Wedi anfon yr’.
Press OK.
Select English on the left by pressing the left button, then ‘OK’.

The meter’s functionality is not impacted by the IHD not working properly, so the meter will still be logging your usage correctly, so please do not worry about that.