Smart meter

My smart reader has changed from English to Welsh. How do I change it back again?

Sometimes, In-Home Displays can switch to Welsh. If this has happened to yours and you need to switch it back to English, here’s how.

Press the ‘OK’ button at the bottom of the In-Home Display, and then the right arrow button until you see ‘Gosodiadau Wedi anfon yr’.

Press OK. This takes you to settings.

Press the right button until you see ‘Dewis iaith Wedi anfon yr’. If this doesn’t work, you may need to try the next option, ‘Clirio Gosodidau Wedi anfon yr’.

Press OK.

Select English on the left by pressing the left button, then ‘OK’.

This should switch your In-Home Display to English.

Thanks

@HenryF

I tried to do this when mine switched to welsh after lots of beeping and scrolling through programmes - it has now frozen completely while trying to clear information! I’ll let battery run out and see what happens when/if it turns on again!