SmartThings App?

It is great your IHD is updating but is this updating your Bulb account if you log in online? New installs have issues calling home to Bulb. I believe Energy control is taken from Bulbs website not from the meter itself.

1 Like

Thanks very much for that update Chapuys. I think this may indeed be the problem because according to the website the last smart ready was in mid December and I only installed the app at the end of December. So it looks like “it has not called home”

SmartThings gets the data via the IHD and not via Bulb - there isn’t a connection between the smart meter sending Bulb data for billing and the IHD sending data to SmartThings for the Energy Control service


thanks for your input which is much appreciated. But I installed the app on the 20th December and up to a minute ago it was still saying “getting the latest data…” as indicated in the pics. I have uninstalled and reinstalled the app but it still has not yet updated.

Any advice would be much appreciated.

The IHD does show “live energy usage” though!! (Confused)

You’re not the only one solomon1, I’m experiencing exactly the same problem. I’ve tried re-adding the device 3 or 4 times now and it still remains stuck on ‘Getting the latest data…’ for SmartThings Energy Control. Not sure what else I can try?

Hi Ian,

Mine just started working yesterday. I have been told the following:

“ …for the graphs to be created there are two bits of info needed by SmartThings - one is the energy data itself (is yours going through?) but the other is the detail of your tariff (normally sent once when you set up and then only again if it changes for any reason).

There were a small number of people who set up over the Xmas period where, for some reason we haven’t worked out yet, the initial tariff detail didn’t get processed through correctly - they picked that up yesterday and processed them - I think we can assume you were one of those affected so sorry for the poor start with SmartThings Energy Control you’ve had - hope you enjoy the service moving forward.”

1 Like

Mine has also started working in the SmartThings app too in the last few days. Thanks @solomon1 for explaining what happened.

My IHD has also updated to 1.9 which is good but it still hasn’t reported readings to Bulb.

1 Like

Hi @chapuys

It isn’t the the IHD which sends the data to Bulb for billing - that goes direct from the Smart Meter via 2G so if your IHD is up to date and Smartthings App is the same then that’s all good - but unfortunately won’t deliver meter data to Bulb for your billing

1 Like

I sorted out my meter readings from the switch to the new meters (the last reading on the old ones and the zero on the new ones) by calling Bulb and I shall be just giving manual readings until it takes over on its own.

1 Like

Glad you’ve got this sorted solomon1. I’m not sure if that will apply to me though as I did have it working previously, but it only started playing up over christmas after my IHD dropped off the network and Bulb had to reboot the comms hub. After that was sorted I haven’t been able to get Smartthings to work since.

Hi Mike,

GUID is - 0C-A2-F4-00-00-3F-48-E4

I’ve also sent an email to the address you specified with instructions to escalate to yourself.



I’m experiencing the same issue. My ihd was installed last year and I have setup integration with SmartThings this week. My data within the SmartThings app is empty.

No matter how many times I reboot either the SmartThings hub or IHD I still have no data in SmartThings.

What options do I have to resolve this issue?



Hi @danielnfletcher - welcome to the Bulb community!

I’ve asked a colleague on our Smart team to take a look at this, however it does sound like it could be an issue with the SmartThings app - you can contact them at and they also have a chat support feature: SmartThings UK Support here. I’ll keep you posted here with any updates! :bulb:

Thanks Jim.

I don’t think the issue is with SmartThings as I’m not seeing any event history in the SmartThings dashboard.

Does the data get pushed to SmartThings or pulled by Smartthings?

@danielnfletcher I’ve just asked a member of the SmartThings team. An interesting question re pushing or pulling data, I’ve never thought about this. I’ll get back to you when I hear from them.

1 Like

@danielnfletcher I’ve got an answer to your question.

We don’t push or pull the data. Samsung are working with the Chameleon (the IHD supplier) cloud database to get the data which populates the app. Connecting the IHD to wifi allows the data to be held in the Chameleon cloud and then Samsung use it to populate SmartThings. It all links up using the device ID so it’s used for the correct graphs etc.

Let us know if you’ve got any further questions on that :slight_smile:

Thanks Sophie.

Is there a way to get in touch with chameleon that you are aware of to troubleshoot this issue with them?

Hi @danielnfletcher

If you wanted to get in touch with Chameleon to discuss these issues with them directly, they can be contacted here: Contact - Chameleon Technology

They might be able to give you a bit more detail on the problem :+1:

After 9 months my smart meter is now working properly, and I’m finally getting gas readings on the IHD. I now want to link it (an IHD6) to the Samsung SmartThings app on my Android phone. I have got as far as entering the GUID, and am waiting for the passphrase to appear on the IHD “Pair CAD to Account” screen. I’ve been waiting for about an hour, certainly a lot longer than the “few minutes” the app suggests it might take.
The IHD says it’s connected to my WiFi, but I can’t see anything that corresponds to it in my router’s list of connected devices - the MAC that’s printed on the IHD doesn’t appear in the router, and in fact I believe I can account for every device that is listed, and that list doesn’t include the IHD. Could this be the problem?
FWIW, the IHD software level is IHD6-CAD-PPMID 1.0 CAD 1.6

Hi @Mark_S

Good to see you again, it’s been a while since you posted :wave:

Glad to hear we’ve gotten your gas readings displaying on your IHD. You’ve done some excellent troubleshooting yourself there, have you tried disconnecting the IHD from the Wifi and reconnecting, and resetting the router too?

I’ve also attached a few helpcentre articles from ourselves and Samsung you may find it useful to look at. As well as that, I’ve raised your issue with our SmartThings team to see if they have any suggestions.